Javítás: A .NET-keretrendszer 4.7 nem támogatott ebben az operációs rendszerben

Tanácsot: Kattintson Ide, Hogy Rögzíti A Windows Hibák És A Rendszer Teljesítményének Optimalizálása

A .Net Framework egy programozási infrastruktúra, amelyet a Microsoft vezet be. Szüksége lesz .Net Framework-re különféle alkalmazások és szolgáltatások futtatásához. A .Net Framework alkalmazást igénylő alkalmazások többsége telepítőfájlokkal is szállítva. Tehát automatikusan települ a rendszerre az alkalmazás telepítésekor. Az alkalmazás telepítésekor azonban hibaüzenet jelenhet meg: „A .NET-keretrendszer 4.7 nem támogatott ezen az operációs rendszeren”. Ez a hiba megakadályozza az alkalmazás sikeres telepítését. Ezt a hibát akkor láthatja, ha a .Net Framework-t önálló alkalmazásként / szolgáltatásként telepíti.

A hiba előfordulásának oka a hibaüzenetben szereplő. Annak ellenére, hogy a .Net Framework támogatott a Windows 10 rendszeren, de nem kompatibilis a Windows 10 összes verziójával. Tehát, ha ezt az üzenetet látja, akkor a hiba legvalószínűbb oka az, hogy egy Windows 10 verziót futtat, amely nem kompatibilis a .Net keretrendszerrel.

1. módszer: Frissítse a Windows 10 rendszert

Az egyetlen megoldás erre a problémára a Windows 10 egyszerű frissítése. Javasoljuk, hogy ellenőrizze a Windows frissítéseket, még akkor is, ha a Windows 10 legújabb verziója van. Mivel a problémát nem kompatibilis operációs rendszer okozza, az összes elérhető Windows 10 telepítése a frissítések valószínűleg megoldják a problémát. A Windows 10 pontos verzióját és a .Net Framework által megkövetelt verziót az alábbiakban ismertetett módon is ellenőrizheti.

  1. Tartsa nyomva a Windows gombot és nyomja meg az R gombot
  2. Írja be a winver alkalmazást, és nyomja meg az Enter billentyűt

  1. Az Ön verzióját meg kell említeni az újonnan megnyílt ablakban. A verzió utáni szám (a második sorban) az Ön verziószáma. A szám 1507 vagy 1709 lehet. Az első 2 számjegy az év, a második 2 a hónapot jelöli. Tehát ha van egy 1709-es verziója, akkor ez azt jelenti, hogy egy 2017. szeptemberében kiadott verziót futtat

  1. Most meg kell győződnie arról, hogy rendelkezik-e a .Net-keretrendszerrel kompatibilis Windows 10 verzióval. Kattintson ide, majd kattintson a Rendszerkövetelmények elemre

Ha megnézi a Támogatott operációs rendszer fejezetet, akkor az a Windows 10 Anniversary Update és a Windows 10 Creators frissítést tartalmazza . Mivel sok ember nem ismeri az évforduló és az alkotók frissítéseivel társított verziószámot, az alábbiakban említjük őket

  • November frissítés (1511)
  • Évforduló frissítés (14393)
  • Alkotók frissítése (1703)
  • Őszi alkotók frissítése (1709)
  • Tavaszi alkotók frissítése (1803)

Mint láthatja, az Anniversary Update verziószáma 14393, a Creators Update verziója pedig 1703. Tehát, ha az 14393-nál alacsonyabb verzió van, akkor a .Net Framework 4.7 nem telepíthető a Windows 10 rendszerre. Most egyszerűen frissítse a Windows-t, és ellenőrizze, hogy van-e a legújabb Windows 10-es verzió, és próbálkozzon újra.

Érdekes Cikkek